diff options
author | Jesse Noller <jnoller@gmail.com> | 2009-03-31 18:12:35 (GMT) |
---|---|---|
committer | Jesse Noller <jnoller@gmail.com> | 2009-03-31 18:12:35 (GMT) |
commit | 40a6164afa79f6b97e7e40e0f35f6081fde437c2 (patch) | |
tree | 3451eabd1be9e42982a3d13ef770bd924e6377b1 /setup.py | |
parent | 3476d1279f469125c62bcea8a84ab65c1e271152 (diff) | |
download | cpython-40a6164afa79f6b97e7e40e0f35f6081fde437c2.zip cpython-40a6164afa79f6b97e7e40e0f35f6081fde437c2.tar.gz cpython-40a6164afa79f6b97e7e40e0f35f6081fde437c2.tar.bz2 |
Apply patch for netbsd multiprocessing support
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 9 |
1 files changed, 9 insertions, 0 deletions
@@ -1280,6 +1280,15 @@ class PyBuildExt(build_ext): ) libraries = [] + elif platform.startswith('netbsd'): + macros = dict( # at least NetBSD 5 + HAVE_SEM_OPEN=1, + HAVE_SEM_TIMEDWAIT=0, + HAVE_FD_TRANSFER=1, + HAVE_BROKEN_SEM_GETVALUE=1 + ) + libraries = [] + else: # Linux and other unices macros = dict( HAVE_SEM_OPEN=1, |