summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorFredrik Lundh <fredrik@pythonware.com>2005-12-14 18:46:16 (GMT)
committerFredrik Lundh <fredrik@pythonware.com>2005-12-14 18:46:16 (GMT)
commit4c86ec651e4f251a9cf5a200d3521ea28566d3a0 (patch)
tree20485eb32049f8c5f2bc08f6d99dab289c417a46 /setup.py
parent9ed730603112667b12cbbfb9c2af502e85bf06c4 (diff)
downloadcpython-4c86ec651e4f251a9cf5a200d3521ea28566d3a0.zip
cpython-4c86ec651e4f251a9cf5a200d3521ea28566d3a0.tar.gz
cpython-4c86ec651e4f251a9cf5a200d3521ea28566d3a0.tar.bz2
added cElementTree/_elementtree build stuff and wrapper module
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py11
1 files changed, 11 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 8ec8cb0..462e76b 100644
--- a/setup.py
+++ b/setup.py
@@ -841,6 +841,17 @@ class PyBuildExt(build_ext):
],
))
+ # Fredrik Lundh's cElementTree module. Note that this also
+ # uses expat (via the CAPI hook in pyexpat).
+
+ if os.path.isfile('Modules/_elementtree.c'):
+ define_macros.append(('USE_PYEXPAT_CAPI', None))
+ exts.append(Extension('_elementtree',
+ define_macros = define_macros,
+ include_dirs = [expatinc],
+ sources = ['_elementtree.c'],
+ ))
+
# Hye-Shik Chang's CJKCodecs modules.
if have_unicode:
exts.append(Extension('_multibytecodec',