summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorAndrew M. Kuchling <amk@amk.ca>2001-08-16 20:30:18 (GMT)
committerAndrew M. Kuchling <amk@amk.ca>2001-08-16 20:30:18 (GMT)
commit5aa3c4af76a1ed08cf275bb049cfa3ebe9758386 (patch)
tree4f610dff3440d61db34c59fa3b54bcac7e1eb60b /setup.py
parentdb7aed5219b5c96db0eeb33262f986faa515d6bc (diff)
downloadcpython-5aa3c4af76a1ed08cf275bb049cfa3ebe9758386.zip
cpython-5aa3c4af76a1ed08cf275bb049cfa3ebe9758386.tar.gz
cpython-5aa3c4af76a1ed08cf275bb049cfa3ebe9758386.tar.bz2
Link readline module with ncurses in preference to termcap. [Bug ##441580]
Remove pointless comment
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py8
1 files changed, 5 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index e717411..8d97854 100644
--- a/setup.py
+++ b/setup.py
@@ -310,7 +310,10 @@ class PyBuildExt(build_ext):
# readline
if self.compiler.find_library_file(lib_dirs, 'readline'):
readline_libs = ['readline']
- if self.compiler.find_library_file(lib_dirs +
+ if self.compiler.find_library_file(lib_dirs,
+ 'ncurses'):
+ readline_libs.append('ncurses')
+ elif self.compiler.find_library_file(lib_dirs +
['/usr/lib/termcap'],
'termcap'):
readline_libs.append('termcap')
@@ -318,8 +321,7 @@ class PyBuildExt(build_ext):
library_dirs=['/usr/lib/termcap'],
libraries=readline_libs) )
- # The crypt module is now disabled by default because it breaks builds
- # on many systems (where -lcrypt is needed), e.g. Linux (I believe).
+ # crypt module.
if self.compiler.find_library_file(lib_dirs, 'crypt'):
libs = ['crypt']