summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorMartin v. Löwis <martin@v.loewis.de>2006-08-09 23:42:18 (GMT)
committerMartin v. Löwis <martin@v.loewis.de>2006-08-09 23:42:18 (GMT)
commit73f12a33f7fffb820cb90487ba962598c0f0d275 (patch)
tree5d8203c9867746286b8156d756f344a8f342e2a5 /setup.py
parent53f2b5fab2f525342dbb69f6f2d5eed978c7883f (diff)
downloadcpython-73f12a33f7fffb820cb90487ba962598c0f0d275.zip
cpython-73f12a33f7fffb820cb90487ba962598c0f0d275.tar.gz
cpython-73f12a33f7fffb820cb90487ba962598c0f0d275.tar.bz2
Add some commentary on -mimpure-text.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py8
1 files changed, 8 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 1ee370a..5d71181 100644
--- a/setup.py
+++ b/setup.py
@@ -1369,6 +1369,14 @@ class PyBuildExt(build_ext):
## extra_link_args.extend(['-read_only_relocs', 'warning'])
elif sys.platform == 'sunos5':
+ # XXX This shouldn't be necessary; it appears that some
+ # of the assembler code is non-PIC (i.e. it has relocations
+ # when it shouldn't. The proper fix would be to rewrite
+ # the assembler code to be PIC.
+ # This only works with GCC; the Sun compiler likely refuses
+ # this option. If you want to compile ctypes with the Sun
+ # compiler, please research a proper solution, instead of
+ # finding some -z option for the Sun compiler.
extra_link_args.append('-mimpure-text')
ext = Extension('_ctypes',