summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorChristian Heimes <christian@cheimes.de>2008-01-25 12:18:43 (GMT)
committerChristian Heimes <christian@cheimes.de>2008-01-25 12:18:43 (GMT)
commit7f39c9fcbba0cc59293d80a7bbcbb8bca62790ee (patch)
tree45d87f47f89cb721ce974534de75b3d42079d793 /setup.py
parent5f95a79b2bf395d114cac2bb74edb6c327ea0a34 (diff)
downloadcpython-7f39c9fcbba0cc59293d80a7bbcbb8bca62790ee.zip
cpython-7f39c9fcbba0cc59293d80a7bbcbb8bca62790ee.tar.gz
cpython-7f39c9fcbba0cc59293d80a7bbcbb8bca62790ee.tar.bz2
Backport of several functions from Python 3.0 to 2.6 including PyUnicode_FromString, PyUnicode_Format and PyLong_From/AsSsize_t. The functions are partly required for the backport of the bytearray type and _fileio module. They should also make it easier to port C to 3.0.
First chapter of the Python 3.0 io framework back port: _fileio The next step depends on a working bytearray type which itself depends on a backport of the nwe buffer API.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 2 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 58481bb..c13c4cf 100644
--- a/setup.py
+++ b/setup.py
@@ -420,6 +420,8 @@ class PyBuildExt(build_ext):
exts.append( Extension("_heapq", ["_heapqmodule.c"]) )
# operator.add() and similar goodies
exts.append( Extension('operator', ['operator.c']) )
+ # Python 3.0 _fileio module
+ exts.append( Extension("_fileio", ["_fileio.c"]) )
# _functools
exts.append( Extension("_functools", ["_functoolsmodule.c"]) )
# Python C API test module