summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorGregory P. Smith <greg@mad-scientist.com>2008-05-26 19:29:14 (GMT)
committerGregory P. Smith <greg@mad-scientist.com>2008-05-26 19:29:14 (GMT)
commit8f1a4a68289c9ec4181f45f9ecc648fdf1050566 (patch)
treecc00871a0ae2b643de8c8f84d0f58ecd345a161a /setup.py
parent572226cad83ce164d6885cc051a79dd57a1dc862 (diff)
downloadcpython-8f1a4a68289c9ec4181f45f9ecc648fdf1050566.zip
cpython-8f1a4a68289c9ec4181f45f9ecc648fdf1050566.tar.gz
cpython-8f1a4a68289c9ec4181f45f9ecc648fdf1050566.tar.bz2
Allow BerlekeyDB up through 4.7. I doubt any of our unixy buildbots even have
that installed yet but the module code supports it.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py5
1 files changed, 1 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index 8ed4486..c8cbbcc 100644
--- a/setup.py
+++ b/setup.py
@@ -687,10 +687,7 @@ class PyBuildExt(build_ext):
# a release. Most open source OSes come with one or more
# versions of BerkeleyDB already installed.
- max_db_ver = (4, 5) # XXX(gregory.p.smith): 4.6 "works" but seems to
- # have issues on many platforms. I've temporarily
- # disabled 4.6 to see what the odd platform
- # buildbots say.
+ max_db_ver = (4, 7)
min_db_ver = (3, 3)
db_setup_debug = False # verbose debug prints from this script?