summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorMichael W. Hudson <mwh@python.net>2002-01-23 15:07:46 (GMT)
committerMichael W. Hudson <mwh@python.net>2002-01-23 15:07:46 (GMT)
commitaf14289c5426743015dbbe0567e2c2677f1bff0c (patch)
treecbb840fb24685db13ca53eeb4b74a9b69463ffa8 /setup.py
parent5b10910d7a1f9543568aba732af3881c85e9289d (diff)
downloadcpython-af14289c5426743015dbbe0567e2c2677f1bff0c.zip
cpython-af14289c5426743015dbbe0567e2c2677f1bff0c.tar.gz
cpython-af14289c5426743015dbbe0567e2c2677f1bff0c.tar.bz2
Fix for
[ #433775 ] module build dir first in test import though not in the way the summary would suggest; use imp.load_dynamic() in setup.py to ensure we're testing the dynamic object we think we are.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py7
1 files changed, 5 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index ae08f4a..6fc9360 100644
--- a/setup.py
+++ b/setup.py
@@ -3,7 +3,7 @@
__version__ = "$Revision$"
-import sys, os, getopt
+import sys, os, getopt, imp
from distutils import sysconfig
from distutils import text_file
from distutils.errors import *
@@ -168,8 +168,11 @@ class PyBuildExt(build_ext):
'WARNING: skipping import check for Carbon-based "%s"' %
ext.name)
return
+ ext_filename = os.path.join(
+ self.build_lib,
+ self.get_ext_filename(self.get_ext_fullname(ext.name)))
try:
- __import__(ext.name)
+ imp.load_dynamic(ext.name, ext_filename)
except ImportError:
self.announce('WARNING: removing "%s" since importing it failed' %
ext.name)