summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorGregory P. Smith <greg@mad-scientist.com>2006-06-05 23:38:06 (GMT)
committerGregory P. Smith <greg@mad-scientist.com>2006-06-05 23:38:06 (GMT)
commitd792392db4b63bea14b40e3f6e3c41ab4eb6e6fa (patch)
tree29b5a051033dd842826f11f6761bf8a4e9fc0b7a /setup.py
parentc169e9f19cd53c2501a8dd9c906c980ea4105d16 (diff)
downloadcpython-d792392db4b63bea14b40e3f6e3c41ab4eb6e6fa.zip
cpython-d792392db4b63bea14b40e3f6e3c41ab4eb6e6fa.tar.gz
cpython-d792392db4b63bea14b40e3f6e3c41ab4eb6e6fa.tar.bz2
add depends = ['md5.h'] to the _md5 module extension for correctness sake.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 3 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 932a2ab..bd9b8b8 100644
--- a/setup.py
+++ b/setup.py
@@ -582,7 +582,9 @@ class PyBuildExt(build_ext):
# The _md5 module implements the RSA Data Security, Inc. MD5
# Message-Digest Algorithm, described in RFC 1321. The
# necessary files md5.c and md5.h are included here.
- exts.append( Extension('_md5', ['md5module.c', 'md5.c']) )
+ exts.append( Extension('_md5',
+ sources = ['md5module.c', 'md5.c'],
+ depends = ['md5.h']) )
if (openssl_ver < 0x00908000):
# OpenSSL doesn't do these until 0.9.8 so we'll bring our own hash