summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorJack Jansen <jack.jansen@cwi.nl>2001-11-01 14:44:15 (GMT)
committerJack Jansen <jack.jansen@cwi.nl>2001-11-01 14:44:15 (GMT)
commitf49c6f9954aa59e29c8b392347646f95cbf8215a (patch)
tree1648bab6df16f1d5b0f97ad890c5b83b9e3a572f /setup.py
parent8cc705eabcea0436ba51ff5eb87aafa82521d2b4 (diff)
downloadcpython-f49c6f9954aa59e29c8b392347646f95cbf8215a.zip
cpython-f49c6f9954aa59e29c8b392347646f95cbf8215a.tar.gz
cpython-f49c6f9954aa59e29c8b392347646f95cbf8215a.tar.bz2
The import check in setup.py fails on Mac OS X for Carbon-based modules
if you are not building while logged in to the console (you cannot connect to the window server, so the Carbon library doesn't initialize). Added a quick hack to skip the import test, with a warning, for modules linked against Carbon.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py5
1 files changed, 5 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index f9903ef..c15bd7c 100644
--- a/setup.py
+++ b/setup.py
@@ -154,6 +154,11 @@ class PyBuildExt(build_ext):
self.announce('WARNING: building of extension "%s" failed: %s' %
(ext.name, sys.exc_info()[1]))
return
+ # Workaround for Mac OS X: The Carbon-based modules cannot be
+ # reliably imported into a command-line Python
+ if 'Carbon' in ext.extra_link_args:
+ self.announce('WARNING: skipping import check for Carbon-based "%s"' % ext.name)
+ return
try:
__import__(ext.name)
except ImportError: