diff options
author | Mark Dickinson <dickinsm@gmail.com> | 2009-12-21 15:22:00 (GMT) |
---|---|---|
committer | Mark Dickinson <dickinsm@gmail.com> | 2009-12-21 15:22:00 (GMT) |
commit | 12748b003c69765e611a7c1782310f33f806607d (patch) | |
tree | 927cdb616ba9ceccecebd32e22585864af10a76a /setup.py | |
parent | 08dca0d6daf46eecb758c8765fdb592211122d47 (diff) | |
download | cpython-12748b003c69765e611a7c1782310f33f806607d.zip cpython-12748b003c69765e611a7c1782310f33f806607d.tar.gz cpython-12748b003c69765e611a7c1782310f33f806607d.tar.bz2 |
Issue #7518: Move substitute definitions of C99 math functions from
pymath.c to Modules/_math.c.
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 4 |
1 files changed, 2 insertions, 2 deletions
@@ -410,9 +410,9 @@ class PyBuildExt(build_ext): # array objects exts.append( Extension('array', ['arraymodule.c']) ) # complex math library functions - exts.append( Extension('cmath', ['cmathmodule.c'], + exts.append( Extension('cmath', ['cmathmodule.c', '_math.c'], + depends=['_math.h'], libraries=math_libs) ) - # math library functions, e.g. sin() exts.append( Extension('math', ['mathmodule.c', '_math.c'], depends=['_math.h'], |