summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorMark Dickinson <dickinsm@gmail.com>2009-12-21 15:22:00 (GMT)
committerMark Dickinson <dickinsm@gmail.com>2009-12-21 15:22:00 (GMT)
commit12748b003c69765e611a7c1782310f33f806607d (patch)
tree927cdb616ba9ceccecebd32e22585864af10a76a /setup.py
parent08dca0d6daf46eecb758c8765fdb592211122d47 (diff)
downloadcpython-12748b003c69765e611a7c1782310f33f806607d.zip
cpython-12748b003c69765e611a7c1782310f33f806607d.tar.gz
cpython-12748b003c69765e611a7c1782310f33f806607d.tar.bz2
Issue #7518: Move substitute definitions of C99 math functions from
pymath.c to Modules/_math.c.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index bad88f7..f25b829 100644
--- a/setup.py
+++ b/setup.py
@@ -410,9 +410,9 @@ class PyBuildExt(build_ext):
# array objects
exts.append( Extension('array', ['arraymodule.c']) )
# complex math library functions
- exts.append( Extension('cmath', ['cmathmodule.c'],
+ exts.append( Extension('cmath', ['cmathmodule.c', '_math.c'],
+ depends=['_math.h'],
libraries=math_libs) )
-
# math library functions, e.g. sin()
exts.append( Extension('math', ['mathmodule.c', '_math.c'],
depends=['_math.h'],