summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorGerhard Häring <gh@ghaering.de>2010-03-05 09:12:37 (GMT)
committerGerhard Häring <gh@ghaering.de>2010-03-05 09:12:37 (GMT)
commit3bbb67273a8c146a38de91080a37e716e2699622 (patch)
tree19a3d1e79cb51cc42760af73724c4f4615d4c21c /setup.py
parent2bb66e03b72ae5a0468dab0b7020316f31c8cfdf (diff)
downloadcpython-3bbb67273a8c146a38de91080a37e716e2699622.zip
cpython-3bbb67273a8c146a38de91080a37e716e2699622.tar.gz
cpython-3bbb67273a8c146a38de91080a37e716e2699622.tar.bz2
Merged code from pysqlite 2.6.0.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 2 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 6327879..c65f286 100644
--- a/setup.py
+++ b/setup.py
@@ -955,6 +955,8 @@ class PyBuildExt(build_ext):
else:
sqlite_defines.append(('MODULE_NAME', '\\"sqlite3\\"'))
+ # Comment this out if you want the sqlite3 module to be able to load extensions.
+ sqlite_defines.append(("SQLITE_OMIT_LOAD_EXTENSION", "1"))
if sys.platform == 'darwin':
# In every directory on the search path search for a dynamic