diff options
author | Stefan Krah <stefan@bytereef.org> | 2010-06-04 09:49:20 (GMT) |
---|---|---|
committer | Stefan Krah <stefan@bytereef.org> | 2010-06-04 09:49:20 (GMT) |
commit | 4d32c9c114dda7ebff8caeae9f4f595f2830d646 (patch) | |
tree | 76a548c795c840d9387cace06f1d421857649daf /setup.py | |
parent | 5e2b27b5e5c55608d120a643232dd77f2634de87 (diff) | |
download | cpython-4d32c9c114dda7ebff8caeae9f4f595f2830d646.zip cpython-4d32c9c114dda7ebff8caeae9f4f595f2830d646.tar.gz cpython-4d32c9c114dda7ebff8caeae9f4f595f2830d646.tar.bz2 |
Detect missing ldd on all systems.
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 3 |
1 files changed, 2 insertions, 1 deletions
@@ -15,6 +15,7 @@ from distutils.core import Extension, setup from distutils.command.build_ext import build_ext from distutils.command.install import install from distutils.command.install_lib import install_lib +from distutils.spawn import find_executable # Were we compiled --with-pydebug or with #define Py_DEBUG? COMPILED_WITH_PYDEBUG = hasattr(sys, 'gettotalrefcount') @@ -591,7 +592,7 @@ class PyBuildExt(build_ext): readline_termcap_library = "" curses_library = "" # Determine if readline is already linked against curses or tinfo. - if do_readline and platform != 'darwin': # OS X does not have ldd. + if do_readline and find_executable('ldd'): fp = os.popen("ldd %s" % do_readline) for ln in fp: if 'curses' in ln: |