summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorBenjamin Peterson <benjamin@python.org>2009-12-30 02:58:50 (GMT)
committerBenjamin Peterson <benjamin@python.org>2009-12-30 02:58:50 (GMT)
commit500ce2338485b863880b0b9f69007ffed94e11ee (patch)
tree4ca210be5732094f4c5f9ee284cc4c0f789e2f83 /setup.py
parent3c8a24e6d925dce957d142beaa47782c5697239a (diff)
downloadcpython-500ce2338485b863880b0b9f69007ffed94e11ee.zip
cpython-500ce2338485b863880b0b9f69007ffed94e11ee.tar.gz
cpython-500ce2338485b863880b0b9f69007ffed94e11ee.tar.bz2
only build the nis module when the headers are found #7589
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index f25b829..d2334e7 100644
--- a/setup.py
+++ b/setup.py
@@ -1088,7 +1088,7 @@ class PyBuildExt(build_ext):
missing.append('resource')
# Sun yellow pages. Some systems have the functions in libc.
- if platform not in ['cygwin', 'atheos', 'qnx6']:
+ if platform not in ['cygwin', 'atheos', 'qnx6'] and find_file('rpcsvc/yp_prot.h', inc_dirs, []) is not None:
if (self.compiler_obj.find_library_file(lib_dirs, 'nsl')):
libs = ['nsl']
else: