summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorSkip Montanaro <skip@pobox.com>2008-10-07 02:04:16 (GMT)
committerSkip Montanaro <skip@pobox.com>2008-10-07 02:04:16 (GMT)
commit593e66fd432d2cdd55b5b3113098cb571e70470b (patch)
tree2edcf99827bc677833b0ffe1b1f09751d7ca72dd /setup.py
parent7e17a76622279ac7793186a4d01fce0a9c359ef1 (diff)
downloadcpython-593e66fd432d2cdd55b5b3113098cb571e70470b.zip
cpython-593e66fd432d2cdd55b5b3113098cb571e70470b.tar.gz
cpython-593e66fd432d2cdd55b5b3113098cb571e70470b.tar.bz2
backport
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index da10fdf..36a0d77 100644
--- a/setup.py
+++ b/setup.py
@@ -320,12 +320,13 @@ class PyBuildExt(build_ext):
# the environment variable is not set even though the value were passed
# into configure and stored in the Makefile (issue found on OS X 10.3).
for env_var, arg_name, dir_list in (
+ ('LDFLAGS', '-R', self.compiler.runtime_library_dirs),
('LDFLAGS', '-L', self.compiler.library_dirs),
('CPPFLAGS', '-I', self.compiler.include_dirs)):
env_val = sysconfig.get_config_var(env_var)
if env_val:
# To prevent optparse from raising an exception about any
- # options in env_val that is doesn't know about we strip out
+ # options in env_val that it doesn't know about we strip out
# all double dashes and any dashes followed by a character
# that is not for the option we are dealing with.
#