summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorAntoine Pitrou <solipsis@pitrou.net>2010-09-07 14:55:24 (GMT)
committerAntoine Pitrou <solipsis@pitrou.net>2010-09-07 14:55:24 (GMT)
commit857298100b9a5fa5bbcafb2ff578418bc6750e58 (patch)
tree395cb55b506ec1953338bcfb9dd394258939ec49 /setup.py
parente80513c207e7f24bfcb5bdd5113c92ef63f0c632 (diff)
downloadcpython-857298100b9a5fa5bbcafb2ff578418bc6750e58.zip
cpython-857298100b9a5fa5bbcafb2ff578418bc6750e58.tar.gz
cpython-857298100b9a5fa5bbcafb2ff578418bc6750e58.tar.bz2
Merged revisions 84584 via svnmerge from
svn+ssh://pythondev@svn.python.org/python/branches/py3k ........ r84584 | antoine.pitrou | 2010-09-07 16:52:42 +0200 (mar., 07 sept. 2010) | 4 lines Issue #4026: Make the fcntl extension build under AIX. Patch by Sébastien Sablé. ........
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py6
1 files changed, 5 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 36257ed..0ed2bae 100644
--- a/setup.py
+++ b/setup.py
@@ -529,7 +529,11 @@ class PyBuildExt(build_ext):
# supported...)
# fcntl(2) and ioctl(2)
- exts.append( Extension('fcntl', ['fcntlmodule.c']) )
+ libs = []
+ if (config_h_vars.get('FLOCK_NEEDS_LIBBSD', False)):
+ # May be necessary on AIX for flock function
+ libs = ['bsd']
+ exts.append( Extension('fcntl', ['fcntlmodule.c'], libraries=libs) )
# pwd(3)
exts.append( Extension('pwd', ['pwdmodule.c']) )
# grp(3)