diff options
author | Matthias Klose <doko@ubuntu.com> | 2010-04-21 21:45:30 (GMT) |
---|---|---|
committer | Matthias Klose <doko@ubuntu.com> | 2010-04-21 21:45:30 (GMT) |
commit | ca6d9e9225ecc53fc62eff2c3058a2eb1dbfa4e8 (patch) | |
tree | a36808fe59c1bc0ab8dab303bc53cb9393edd009 /setup.py | |
parent | 1a9e9f282e92d9cef7fbc992b74da6fe8d1c52cd (diff) | |
download | cpython-ca6d9e9225ecc53fc62eff2c3058a2eb1dbfa4e8.zip cpython-ca6d9e9225ecc53fc62eff2c3058a2eb1dbfa4e8.tar.gz cpython-ca6d9e9225ecc53fc62eff2c3058a2eb1dbfa4e8.tar.bz2 |
setup.py: search ffi.h in include dirs, if LIBFFI_INCLUDEDIR is empty.
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 2 |
1 files changed, 1 insertions, 1 deletions
@@ -1808,7 +1808,7 @@ class PyBuildExt(build_ext): inc_dirs.append('/usr/include/ffi') ffi_inc = [sysconfig.get_config_var("LIBFFI_INCLUDEDIR")] - if not ffi_inc: + if not ffi_inc or ffi_inc[0] == '': ffi_inc = find_file('ffi.h', [], inc_dirs) if ffi_inc is not None: ffi_h = ffi_inc[0] + '/ffi.h' |