summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorRonald Oussoren <ronaldoussoren@mac.com>2010-06-27 12:36:16 (GMT)
committerRonald Oussoren <ronaldoussoren@mac.com>2010-06-27 12:36:16 (GMT)
commitcd17213e8e8389ea4bce1641d3878ad67b2f7782 (patch)
tree12ba2f2e84f23848856cee5f218a235a99dcd4df /setup.py
parentad72bcc864cf019cad9a4594d7ec9550d7f93e71 (diff)
downloadcpython-cd17213e8e8389ea4bce1641d3878ad67b2f7782.zip
cpython-cd17213e8e8389ea4bce1641d3878ad67b2f7782.tar.gz
cpython-cd17213e8e8389ea4bce1641d3878ad67b2f7782.tar.bz2
Two small fixes for the support for SDKs on MacOSX:
1) The code that checks if an path should be located in the SDK explicitly excludes /usr/local. This fixes issue9046 2) The SDK variant for filtering "db_dirs_to_check" in setup.py was not doing anything because of a missing assignment.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 1a403d9..464242d 100644
--- a/setup.py
+++ b/setup.py
@@ -47,7 +47,7 @@ def is_macosx_sdk_path(path):
"""
Returns True if 'path' can be located in an OSX SDK
"""
- return path.startswith('/usr/') or path.startswith('/System/')
+ return (path.startswith('/usr/') and not path.startswith('/usr/local')) or path.startswith('/System/')
def find_file(filename, std_dirs, paths):
"""Searches for the directory where a given file is located,
@@ -922,6 +922,7 @@ class PyBuildExt(build_ext):
else:
if os.path.isdir(dn):
tmp.append(dn)
+ db_dirs_to_check = tmp
# Look for a version specific db-X.Y before an ambiguoius dbX
# XXX should we -ever- look for a dbX name? Do any