diff options
author | Hirokazu Yamamoto <ocean-city@m2.ccsnet.ne.jp> | 2008-10-03 17:34:49 (GMT) |
---|---|---|
committer | Hirokazu Yamamoto <ocean-city@m2.ccsnet.ne.jp> | 2008-10-03 17:34:49 (GMT) |
commit | 1ae415cbee7c35f00a167df84a6ca0759d66a4e5 (patch) | |
tree | 82e3e970ef6544d220d4088d2f1ebcf9621e6ca9 /setup.py | |
parent | 081bb457ab1f84beaed7c73754c32b87b06a3d40 (diff) | |
download | cpython-1ae415cbee7c35f00a167df84a6ca0759d66a4e5.zip cpython-1ae415cbee7c35f00a167df84a6ca0759d66a4e5.tar.gz cpython-1ae415cbee7c35f00a167df84a6ca0759d66a4e5.tar.bz2 |
Issue #1706863: Fixed "'NoneType' object has no attribute 'rfind'" error when sqlite libfile not found.
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 3 |
1 files changed, 2 insertions, 1 deletions
@@ -934,7 +934,8 @@ class PyBuildExt(build_ext): ] sqlite_libfile = self.compiler.find_library_file( sqlite_dirs_to_check + lib_dirs, 'sqlite3') - sqlite_libdir = [os.path.abspath(os.path.dirname(sqlite_libfile))] + if sqlite_libfile: + sqlite_libdir = [os.path.abspath(os.path.dirname(sqlite_libfile))] if sqlite_incdir and sqlite_libdir: sqlite_srcs = ['_sqlite/cache.c', |