diff options
author | Ned Deily <nad@acm.org> | 2013-10-19 04:33:57 (GMT) |
---|---|---|
committer | Ned Deily <nad@acm.org> | 2013-10-19 04:33:57 (GMT) |
commit | 6ea3c9b22a3e81e6484a30c1d64c6a859a40da6a (patch) | |
tree | 5becc6c60c003ab8b87f7953e5cc50836b241be8 /setup.py | |
parent | 11f880a73b71e6843b5d697a2a181fda37c4983f (diff) | |
download | cpython-6ea3c9b22a3e81e6484a30c1d64c6a859a40da6a.zip cpython-6ea3c9b22a3e81e6484a30c1d64c6a859a40da6a.tar.gz cpython-6ea3c9b22a3e81e6484a30c1d64c6a859a40da6a.tar.bz2 |
Ensure setup.py looks for zlib.h in an OS X SDK.
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 2 |
1 files changed, 2 insertions, 0 deletions
@@ -1389,6 +1389,8 @@ class PyBuildExt(build_ext): zlib_h = zlib_inc[0] + '/zlib.h' version = '"0.0.0"' version_req = '"1.1.3"' + if host_platform == 'darwin' and is_macosx_sdk_path(zlib_h): + zlib_h = os.path.join(macosx_sdk_root(), zlib_h[1:]) fp = open(zlib_h) while 1: line = fp.readline() |