summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorPetri Lehtinen <petri@digip.org>2013-02-23 16:05:28 (GMT)
committerPetri Lehtinen <petri@digip.org>2013-02-23 16:05:28 (GMT)
commitc23178ba36097764bc3c1c33aa8dba2a0871e778 (patch)
tree3156993dd147b1c4c61fc3041b0bcfa9231ac39b /setup.py
parent0a4a7e13f32d0bbbcaea30b4ace9feee3a73e8b1 (diff)
downloadcpython-c23178ba36097764bc3c1c33aa8dba2a0871e778.zip
cpython-c23178ba36097764bc3c1c33aa8dba2a0871e778.tar.gz
cpython-c23178ba36097764bc3c1c33aa8dba2a0871e778.tar.bz2
Issue #5033: Fix building of the sqlite3 extension module
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 24ce8bc..b728bf6 100644
--- a/setup.py
+++ b/setup.py
@@ -1114,7 +1114,7 @@ class PyBuildExt(build_ext):
if sqlite_setup_debug: print "sqlite: found %s"%f
incf = open(f).read()
m = re.search(
- r'\s*.*#\s*.*define\s.*SQLITE_VERSION\W*"(.*)"', incf)
+ r'\s*.*#\s*.*define\s.*SQLITE_VERSION\W*"([\d\.]*)"', incf)
if m:
sqlite_version = m.group(1)
sqlite_version_tuple = tuple([int(x)