diff options
author | Petri Lehtinen <petri@digip.org> | 2013-02-23 16:05:28 (GMT) |
---|---|---|
committer | Petri Lehtinen <petri@digip.org> | 2013-02-23 16:05:28 (GMT) |
commit | c23178ba36097764bc3c1c33aa8dba2a0871e778 (patch) | |
tree | 3156993dd147b1c4c61fc3041b0bcfa9231ac39b /setup.py | |
parent | 0a4a7e13f32d0bbbcaea30b4ace9feee3a73e8b1 (diff) | |
download | cpython-c23178ba36097764bc3c1c33aa8dba2a0871e778.zip cpython-c23178ba36097764bc3c1c33aa8dba2a0871e778.tar.gz cpython-c23178ba36097764bc3c1c33aa8dba2a0871e778.tar.bz2 |
Issue #5033: Fix building of the sqlite3 extension module
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 2 |
1 files changed, 1 insertions, 1 deletions
@@ -1114,7 +1114,7 @@ class PyBuildExt(build_ext): if sqlite_setup_debug: print "sqlite: found %s"%f incf = open(f).read() m = re.search( - r'\s*.*#\s*.*define\s.*SQLITE_VERSION\W*"(.*)"', incf) + r'\s*.*#\s*.*define\s.*SQLITE_VERSION\W*"([\d\.]*)"', incf) if m: sqlite_version = m.group(1) sqlite_version_tuple = tuple([int(x) |