diff options
author | Ronald Oussoren <ronaldoussoren@mac.com> | 2009-03-04 21:30:12 (GMT) |
---|---|---|
committer | Ronald Oussoren <ronaldoussoren@mac.com> | 2009-03-04 21:30:12 (GMT) |
commit | cea1ddb4aa6ccae552ff9838cb07c6802785b8fc (patch) | |
tree | a00213363009e33a243bac4081ff7c70c3f812f2 /setup.py | |
parent | eeafb96b0877b78b1efd341f1103b2a81d5116e1 (diff) | |
download | cpython-cea1ddb4aa6ccae552ff9838cb07c6802785b8fc.zip cpython-cea1ddb4aa6ccae552ff9838cb07c6802785b8fc.tar.gz cpython-cea1ddb4aa6ccae552ff9838cb07c6802785b8fc.tar.bz2 |
Change framework search order when looking for Tcl/Tk on OSX.
This is needed because the system linker looks in /Library/Framework before
it looks in /System/Library frameworks. Without this patch _tkinter will
be unusable when it is compiled on a system that has Tk 8.5 installed in
/Library/Frameworks (and the Apple 8.4 install in /System/Library/Frameworks)
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 2 |
1 files changed, 1 insertions, 1 deletions
@@ -1443,8 +1443,8 @@ class PyBuildExt(build_ext): # different the UNIX search logic is not sharable. from os.path import join, exists framework_dirs = [ - '/System/Library/Frameworks/', '/Library/Frameworks', + '/System/Library/Frameworks/', join(os.getenv('HOME'), '/Library/Frameworks') ] |