diff options
author | Fred Drake <fdrake@acm.org> | 2001-12-06 22:59:54 (GMT) |
---|---|---|
committer | Fred Drake <fdrake@acm.org> | 2001-12-06 22:59:54 (GMT) |
commit | 9028d0a52529a8bc76868ade697511f29614b207 (patch) | |
tree | ef66dec6dba83cec240139ccdafbe09372961e2c /setup.py | |
parent | e3d7622fb3e595db29b690751a00406b0e3cf975 (diff) | |
download | cpython-9028d0a52529a8bc76868ade697511f29614b207.zip cpython-9028d0a52529a8bc76868ade697511f29614b207.tar.gz cpython-9028d0a52529a8bc76868ade697511f29614b207.tar.bz2 |
Visious hackery to solve a build-control problem related to our use of
distutils for the library modules built as shared objects. A better solution
appears possible, but with the threat that the distutils becomes more
magical ("complex").
This closes SF bug #458343.
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 7 |
1 files changed, 7 insertions, 0 deletions
@@ -172,6 +172,13 @@ class PyBuildExt(build_ext): self.get_ext_filename(fullname)) os.remove(ext_filename) + # XXX -- This relies on a Vile HACK in + # distutils.command.build_ext.build_extension(). The + # _built_objects attribute is stored there strictly for + # use here. + for filename in self._built_objects: + os.remove(filename) + def get_platform (self): # Get value of sys.platform platform = sys.platform |