summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorRonald Oussoren <ronaldoussoren@mac.com>2009-09-20 14:18:15 (GMT)
committerRonald Oussoren <ronaldoussoren@mac.com>2009-09-20 14:18:15 (GMT)
commit9f20d9d0ee78f7bd810dfe788a8d1319afbc36e7 (patch)
tree139e1f5b7e05f8504457db5d9a595e5ffb727966 /setup.py
parent956f4b2520ef921daa3ab1083d56d74317505c2e (diff)
downloadcpython-9f20d9d0ee78f7bd810dfe788a8d1319afbc36e7.zip
cpython-9f20d9d0ee78f7bd810dfe788a8d1319afbc36e7.tar.gz
cpython-9f20d9d0ee78f7bd810dfe788a8d1319afbc36e7.tar.bz2
Issue 6877: this patch makes it possible to link the readline extension
to the libedit emulation of the readline API on OSX 10.5 or later. This also adds a minimal testsuite for readline to check that the history manipuation functions have the same interface with both C libraries.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py18
1 files changed, 9 insertions, 9 deletions
diff --git a/setup.py b/setup.py
index adc72c8..d229036 100644
--- a/setup.py
+++ b/setup.py
@@ -546,16 +546,16 @@ class PyBuildExt(build_ext):
# readline
do_readline = self.compiler_obj.find_library_file(lib_dirs, 'readline')
- if platform == 'darwin': # and os.uname()[2] < '9.':
- # MacOSX 10.4 has a broken readline. Don't try to build
- # the readline module unless the user has installed a fixed
- # readline package
- # FIXME: The readline emulation on 10.5 is better, but the
- # readline module doesn't compile out of the box.
- if find_file('readline/rlconf.h', inc_dirs, []) is None:
- do_readline = False
+ if platform == 'darwin':
+ os_release = int(os.uname()[2].split('.')[0])
+ if os_release < 9:
+ # MacOSX 10.4 has a broken readline. Don't try to build
+ # the readline module unless the user has installed a fixed
+ # readline package
+ if find_file('readline/rlconf.h', inc_dirs, []) is None:
+ do_readline = False
if do_readline:
- if sys.platform == 'darwin':
+ if platform == 'darwin' and os_release < 9:
# In every directory on the search path search for a dynamic
# library and then a static library, instead of first looking
# for dynamic libraries on the entiry path.