diff options
author | Brett Cannon <bcannon@gmail.com> | 2004-08-26 01:44:07 (GMT) |
---|---|---|
committer | Brett Cannon <bcannon@gmail.com> | 2004-08-26 01:44:07 (GMT) |
commit | cc8a4f6563395e39d77da9888d0ea3675214ca64 (patch) | |
tree | bc987a4797da09ab0e1bffbf2975e27c77211310 /setup.py | |
parent | 71f55af826481576ffa75f9dc0771e20ab7c1187 (diff) | |
download | cpython-cc8a4f6563395e39d77da9888d0ea3675214ca64.zip cpython-cc8a4f6563395e39d77da9888d0ea3675214ca64.tar.gz cpython-cc8a4f6563395e39d77da9888d0ea3675214ca64.tar.bz2 |
When building with --disable-toolbox-glue under Darwin, skip building any
Mac-specific modules. Before all modules were compiled but would fail thanks
to a dependence on the code included when Python was built without the compiler
flag.
Closes bug #991962.
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 6 |
1 files changed, 4 insertions, 2 deletions
@@ -119,7 +119,8 @@ class PyBuildExt(build_ext): # Platform-dependent module source and include directories platform = self.get_platform() - if platform in ('darwin', 'mac'): + if platform in ('darwin', 'mac') and ("--disable-toolbox-glue" not in + sysconfig.get_config_var("CONFIG_ARGS")): # Mac OS X also includes some mac-specific modules macmoddir = os.path.join(os.getcwd(), srcdir, 'Mac/Modules') moddirlist.append(macmoddir) @@ -789,7 +790,8 @@ class PyBuildExt(build_ext): # SunOS specific modules exts.append( Extension('sunaudiodev', ['sunaudiodev.c']) ) - if platform == 'darwin': + if platform == 'darwin' and ("--disable-toolbox-glue" not in + sysconfig.get_config_var("CONFIG_ARGS")): # Mac OS X specific modules. exts.append( Extension('_CF', ['cf/_CFmodule.c', 'cf/pycfbridge.c'], extra_link_args=['-framework', 'CoreFoundation']) ) |