diff options
author | Jack Jansen <jack.jansen@cwi.nl> | 2001-08-15 13:17:45 (GMT) |
---|---|---|
committer | Jack Jansen <jack.jansen@cwi.nl> | 2001-08-15 13:17:45 (GMT) |
commit | df82e58cd516ea1dcd9d0bfc5622a5239af0392d (patch) | |
tree | 2cae4b1a76af0a59a7eb931d379bed0518fcf5bf /setup.py | |
parent | 31b5323c84f3203ffc8ccf09bf62d1fef10bccd4 (diff) | |
download | cpython-df82e58cd516ea1dcd9d0bfc5622a5239af0392d.zip cpython-df82e58cd516ea1dcd9d0bfc5622a5239af0392d.tar.gz cpython-df82e58cd516ea1dcd9d0bfc5622a5239af0392d.tar.bz2 |
On OSX we should not pass the -shared option to ld: it make the build
of audioop and cmath fail. Removing it seems to have no adverse consequences.
Closes bug #450510.
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 5 |
1 files changed, 4 insertions, 1 deletions
@@ -141,7 +141,10 @@ class PyBuildExt(build_ext): (ccshared,opt) = sysconfig.get_config_vars('CCSHARED','OPT') args['compiler_so'] = compiler + ' ' + opt + ' ' + ccshared if linker_so is not None: - args['linker_so'] = linker_so + ' -shared' + if platform == 'darwin1': + args['linker_so'] = linker_so + else: + args['linker_so'] = linker_so + ' -shared' self.compiler.set_executables(**args) build_ext.build_extensions(self) |