summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorGeorg Brandl <georg@python.org>2007-03-06 17:49:14 (GMT)
committerGeorg Brandl <georg@python.org>2007-03-06 17:49:14 (GMT)
commite95cf1c8a2cba11b38f9c83da659895fbc952466 (patch)
treea06c6613fae57cd8f44ab3fe968d2a4a0eefe729 /setup.py
parent2054ee9b6f268d16e90e4ff30186b5a4a1f91719 (diff)
downloadcpython-e95cf1c8a2cba11b38f9c83da659895fbc952466.zip
cpython-e95cf1c8a2cba11b38f9c83da659895fbc952466.tar.gz
cpython-e95cf1c8a2cba11b38f9c83da659895fbc952466.tar.bz2
Fix cmp vs. key argument for list.sort.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index f19c6d0..6814dac 100644
--- a/setup.py
+++ b/setup.py
@@ -187,7 +187,7 @@ class PyBuildExt(build_ext):
longest = max(longest, max([len(name) for name in self.failed]))
def print_three_column(lst):
- lst.sort(cmp=str.lower)
+ lst.sort(key=str.lower)
# guarantee zip() doesn't drop anything
while len(lst) % 3:
lst.append("")