diff options
author | Erlend Egeberg Aasland <erlend.aasland@innova.no> | 2020-09-07 21:26:54 (GMT) |
---|---|---|
committer | GitHub <noreply@github.com> | 2020-09-07 21:26:54 (GMT) |
commit | 207c321f13cea3fee7f378057864e8c6453f5adf (patch) | |
tree | 394cd3a6f35d1f000e1b0602b3e4ba44151b9232 /setup.py | |
parent | 22748a83d927d3da1beaed771be30887c42b2500 (diff) | |
download | cpython-207c321f13cea3fee7f378057864e8c6453f5adf.zip cpython-207c321f13cea3fee7f378057864e8c6453f5adf.tar.gz cpython-207c321f13cea3fee7f378057864e8c6453f5adf.tar.bz2 |
bpo-40744: Drop support for SQLite pre 3.7.3 (GH-20909)
Remove code required to support SQLite pre 3.7.3.
Co-written-by: Berker Peksag <berker.peksag@gmail.com>
Co-written-by: Sergey Fedoseev <fedoseev.sergey@gmail.com>
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 4 |
1 files changed, 2 insertions, 2 deletions
@@ -1452,7 +1452,6 @@ class PyBuildExt(build_ext): sqlite_setup_debug = False # verbose debug prints from this script? # We hunt for #define SQLITE_VERSION "n.n.n" - # We need to find >= sqlite version 3.3.9, for sqlite3_prepare_v2 sqlite_incdir = sqlite_libdir = None sqlite_inc_paths = [ '/usr/include', '/usr/include/sqlite', @@ -1463,7 +1462,8 @@ class PyBuildExt(build_ext): ] if CROSS_COMPILING: sqlite_inc_paths = [] - MIN_SQLITE_VERSION_NUMBER = (3, 7, 2) + # We need to find >= sqlite version 3.7.3, for sqlite3_create_function_v2() + MIN_SQLITE_VERSION_NUMBER = (3, 7, 3) MIN_SQLITE_VERSION = ".".join([str(x) for x in MIN_SQLITE_VERSION_NUMBER]) |