summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorJack Jansen <jack.jansen@cwi.nl>2003-02-18 10:24:34 (GMT)
committerJack Jansen <jack.jansen@cwi.nl>2003-02-18 10:24:34 (GMT)
commit0feb8c347e4fa4e8860b2fc4f95602cf6621ab09 (patch)
treeb1dfdbe18fb510b6dca08c89467014dedc41e86b /setup.py
parent0c0aad948aa3bc3954514d842d28d08a6cc6112f (diff)
downloadcpython-0feb8c347e4fa4e8860b2fc4f95602cf6621ab09.zip
cpython-0feb8c347e4fa4e8860b2fc4f95602cf6621ab09.tar.gz
cpython-0feb8c347e4fa4e8860b2fc4f95602cf6621ab09.tar.bz2
Don't try to build dl on darwin. It doesn't build out of the box, and it
wouldn't serve a useful purpose anyway.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 01b87eb..3217033 100644
--- a/setup.py
+++ b/setup.py
@@ -734,7 +734,7 @@ class PyBuildExt(build_ext):
if sys.maxint == 0x7fffffff:
# This requires sizeof(int) == sizeof(long) == sizeof(char*)
dl_inc = find_file('dlfcn.h', [], inc_dirs)
- if (dl_inc is not None) and (platform not in ['atheos']):
+ if (dl_inc is not None) and (platform not in ['atheos', 'darwin']):
exts.append( Extension('dl', ['dlmodule.c']) )
# Platform-specific libraries