summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorVictor Stinner <vstinner@redhat.com>2019-04-23 10:26:33 (GMT)
committerGitHub <noreply@github.com>2019-04-23 10:26:33 (GMT)
commit574913479f26b5ff48827861bce68281be01d16e (patch)
tree55f65fb7f0580b50e7b095ff8fa0d6a8b1a77b7b /setup.py
parent84b4784f12d4b8aab2b4cc5a4f5b64f45ec3e5d4 (diff)
downloadcpython-574913479f26b5ff48827861bce68281be01d16e.zip
cpython-574913479f26b5ff48827861bce68281be01d16e.tar.gz
cpython-574913479f26b5ff48827861bce68281be01d16e.tar.bz2
bpo-36635, bpo-36696: Fix setup.py on AIX (GH-12922)
xlc compiler doesn't support "-D define" flag only "-Ddefine".
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py6
1 files changed, 3 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 3d6404f..58c16e8 100644
--- a/setup.py
+++ b/setup.py
@@ -726,12 +726,12 @@ class PyBuildExt(build_ext):
self.add(Extension("_heapq", ["_heapqmodule.c"]))
# C-optimized pickle replacement
self.add(Extension("_pickle", ["_pickle.c"],
- extra_compile_args=['-D Py_BUILD_CORE_MODULE']))
+ extra_compile_args=['-DPy_BUILD_CORE_MODULE']))
# atexit
self.add(Extension("atexit", ["atexitmodule.c"]))
# _json speedups
self.add(Extension("_json", ["_json.c"],
- extra_compile_args=['-D Py_BUILD_CORE_MODULE']))
+ extra_compile_args=['-DPy_BUILD_CORE_MODULE']))
# profiler (_lsprof is for cProfile.py)
self.add(Extension('_lsprof', ['_lsprof.c', 'rotatingtree.c']))
@@ -816,7 +816,7 @@ class PyBuildExt(build_ext):
# Python Internal C API test module
self.add(Extension('_testinternalcapi', ['_testinternalcapi.c'],
- extra_compile_args=['-D Py_BUILD_CORE_MODULE']))
+ extra_compile_args=['-DPy_BUILD_CORE_MODULE']))
# Python PEP-3118 (buffer protocol) test module
self.add(Extension('_testbuffer', ['_testbuffer.c']))