summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorChristian Heimes <christian@python.org>2016-09-07 09:58:24 (GMT)
committerChristian Heimes <christian@python.org>2016-09-07 09:58:24 (GMT)
commit6fe2a75b645044ca2b5dac03e8d850567b547a9a (patch)
tree62e1a5edd46384ff687c96f4f94cf3b0a2bae72e /setup.py
parentdfb9ef13575bcc457544b408fc4e5eca3c5ed9b1 (diff)
downloadcpython-6fe2a75b645044ca2b5dac03e8d850567b547a9a.zip
cpython-6fe2a75b645044ca2b5dac03e8d850567b547a9a.tar.gz
cpython-6fe2a75b645044ca2b5dac03e8d850567b547a9a.tar.bz2
Issue #16113: Add SHA-3 and SHAKE support to hashlib module.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py7
1 files changed, 7 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 5450b7e..6b81569 100644
--- a/setup.py
+++ b/setup.py
@@ -905,6 +905,13 @@ class PyBuildExt(build_ext):
define_macros=blake2_macros,
depends=blake2_deps) )
+ sha3_deps = glob(os.path.join(os.getcwd(), srcdir,
+ 'Modules/_sha3/kcp/*'))
+ sha3_deps.append('hashlib.h')
+ exts.append( Extension('_sha3',
+ ['_sha3/sha3module.c'],
+ depends=sha3_deps))
+
# Modules that provide persistent dictionary-like semantics. You will
# probably want to arrange for at least one of them to be available on
# your machine, though none are defined by default because of library