summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorThomas Klausner <tk@giga.or.at>2022-07-31 08:19:09 (GMT)
committerGitHub <noreply@github.com>2022-07-31 08:19:09 (GMT)
commitae2496245774fd196948f61a064dd2c5410ed34f (patch)
treee1db1724b0bf1785b0d5c60dac491d0de9ebe31a /setup.py
parent6765a784a7d3f0b96410baeb34ccd350474bf051 (diff)
downloadcpython-ae2496245774fd196948f61a064dd2c5410ed34f.zip
cpython-ae2496245774fd196948f61a064dd2c5410ed34f.tar.gz
cpython-ae2496245774fd196948f61a064dd2c5410ed34f.tar.bz2
[3.10] bpo-46053: Fix OSS audio support on NetBSD (GH-30065). (GH-95477)
(cherry picked from commit 2e7e3c4c109928870c1e33d8af36b78e92895594) Co-authored-by: Thomas Klausner <tk@giga.or.at>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 3 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 4894adf..85a2b26 100644
--- a/setup.py
+++ b/setup.py
@@ -1663,6 +1663,9 @@ class PyBuildExt(build_ext):
# Platform-specific libraries
if HOST_PLATFORM.startswith(('linux', 'freebsd', 'gnukfreebsd')):
self.add(Extension('ossaudiodev', ['ossaudiodev.c']))
+ elif HOST_PLATFORM.startswith(('netbsd')):
+ self.add(Extension('ossaudiodev', ['ossaudiodev.c'],
+ libraries=["ossaudio"]))
elif not AIX:
self.missing.append('ossaudiodev')