diff options
author | Miss Islington (bot) <31488909+miss-islington@users.noreply.github.com> | 2021-08-27 11:29:24 (GMT) |
---|---|---|
committer | GitHub <noreply@github.com> | 2021-08-27 11:29:24 (GMT) |
commit | baa8d48230e3ab8a504f39ee800f8852897cb3be (patch) | |
tree | cd0c52ef57074d187f9cf7b47902dbdeaa8524ca /setup.py | |
parent | 719af92e108ea3b31729cb09077673b8f13905d2 (diff) | |
download | cpython-baa8d48230e3ab8a504f39ee800f8852897cb3be.zip cpython-baa8d48230e3ab8a504f39ee800f8852897cb3be.tar.gz cpython-baa8d48230e3ab8a504f39ee800f8852897cb3be.tar.bz2 |
bpo-44997: macOS does not support loadable SQLite extensions (GH-27979)
Authored-by: Ronald Oussoren <ronaldoussoren@mac.com>
(cherry picked from commit 2ec9428e3516b6e7c6583687aa3b39fb96925577)
Co-authored-by: Erlend Egeberg Aasland <erlend.aasland@innova.no>
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 2 |
1 files changed, 2 insertions, 0 deletions
@@ -1603,6 +1603,8 @@ class PyBuildExt(build_ext): # if --enable-loadable-sqlite-extensions configure option is used. if '--enable-loadable-sqlite-extensions' not in sysconfig.get_config_var("CONFIG_ARGS"): sqlite_defines.append(("SQLITE_OMIT_LOAD_EXTENSION", "1")) + elif MACOS and sqlite_incdir == os.path.join(MACOS_SDK_ROOT, "usr/include"): + raise DistutilsError("System version of SQLite does not support loadable extensions") if MACOS: # In every directory on the search path search for a dynamic |