summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorMiss Islington (bot) <31488909+miss-islington@users.noreply.github.com>2021-09-29 14:13:41 (GMT)
committerGitHub <noreply@github.com>2021-09-29 14:13:41 (GMT)
commit412ae8ab10734b72384c969181919cc4eb154406 (patch)
treebf01850dccdded3499a0da906c2fd1b88ef3c07e /setup.py
parent2be4c370c6bfe98a85aa01c5d9c333b804d26197 (diff)
downloadcpython-412ae8ab10734b72384c969181919cc4eb154406.zip
cpython-412ae8ab10734b72384c969181919cc4eb154406.tar.gz
cpython-412ae8ab10734b72384c969181919cc4eb154406.tar.bz2
[3.10] bpo-44394: Ensure libexpat is linked against libm (GH-28617) (GH-28621)
* bpo-44394: Ensure libexpat is linked against libm (GH-28617) (cherry picked from commit 6c1154b9de29e1c9cd3d05f5289543e5cff73895) Co-authored-by: Pablo Galindo Salgado <Pablogsal@gmail.com> Co-authored-by: Ɓukasz Langa <lukasz@langa.pl>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 3 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 3d250e7..a6fcc12 100644
--- a/setup.py
+++ b/setup.py
@@ -1765,7 +1765,9 @@ class PyBuildExt(build_ext):
('XML_POOR_ENTROPY', '1'),
]
extra_compile_args = []
- expat_lib = []
+ # bpo-44394: libexpat uses isnan() of math.h and needs linkage
+ # against the libm
+ expat_lib = ['m']
expat_sources = ['expat/xmlparse.c',
'expat/xmlrole.c',
'expat/xmltok.c']