summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorChristian Heimes <christian@python.org>2018-02-25 09:22:14 (GMT)
committerGitHub <noreply@github.com>2018-02-25 09:22:14 (GMT)
commit5bb9692575f10f4a7c7f1c2c0c70956baf6d5c23 (patch)
tree5738108873b903fcf86a378077012a99f74bda72 /setup.py
parentb7b9225831a729bff84eb7c43bad138416b994fe (diff)
downloadcpython-5bb9692575f10f4a7c7f1c2c0c70956baf6d5c23.zip
cpython-5bb9692575f10f4a7c7f1c2c0c70956baf6d5c23.tar.gz
cpython-5bb9692575f10f4a7c7f1c2c0c70956baf6d5c23.tar.bz2
bpo-32647: Link ctypes extension with libdl. (#5550)
The ctypes module used to depend on indirect linking for dlopen. The shared extension is now explicitly linked against libdl on platforms with dl. Signed-off-by: Christian Heimes <christian@python.org>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 4 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index f4f6e4f..8536c35 100644
--- a/setup.py
+++ b/setup.py
@@ -2005,6 +2005,10 @@ class PyBuildExt(build_ext):
ext.libraries.append(ffi_lib)
self.use_system_libffi = True
+ if sysconfig.get_config_var('HAVE_LIBDL'):
+ # for dlopen, see bpo-32647
+ ext.libraries.append('dl')
+
def _decimal_ext(self):
extra_compile_args = []
undef_macros = []