diff options
author | Barry Warsaw <barry@python.org> | 2011-04-06 19:18:12 (GMT) |
---|---|---|
committer | Barry Warsaw <barry@python.org> | 2011-04-06 19:18:12 (GMT) |
commit | 5ca305a599d487beba642903914f0a55259f9d52 (patch) | |
tree | c3bc9ed4f92b2e5f5374ee065a72dff3338ffb4a /setup.py | |
parent | 8f377a3bbe5588da3328ab816ce5f707aa3c97ac (diff) | |
download | cpython-5ca305a599d487beba642903914f0a55259f9d52.zip cpython-5ca305a599d487beba642903914f0a55259f9d52.tar.gz cpython-5ca305a599d487beba642903914f0a55259f9d52.tar.bz2 |
Issue 11715: Build extension modules on multiarch Debian and Ubuntu by
extending search paths to include multiarch directories.
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 21 |
1 files changed, 21 insertions, 0 deletions
@@ -339,10 +339,31 @@ class PyBuildExt(build_ext): return platform return sys.platform + def add_multiarch_paths(self): + # Debian/Ubuntu multiarch support. + # https://wiki.ubuntu.com/MultiarchSpec + tmpfile = os.path.join(self.build_temp, 'multiarch') + if not os.path.exists(self.build_temp): + os.makedirs(self.build_temp) + ret = os.system( + 'dpkg-architecture -qDEB_HOST_MULTIARCH > %s 2> /dev/null' % + tmpfile) + try: + if ret >> 8 == 0: + with open(tmpfile) as fp: + multiarch_path_component = fp.readline().strip() + add_dir_to_list(self.compiler.library_dirs, + '/usr/lib/' + multiarch_path_component) + add_dir_to_list(self.compiler.include_dirs, + '/usr/include/' + multiarch_path_component) + finally: + os.unlink(tmpfile) + def detect_modules(self): # Ensure that /usr/local is always used add_dir_to_list(self.compiler.library_dirs, '/usr/local/lib') add_dir_to_list(self.compiler.include_dirs, '/usr/local/include') + self.add_multiarch_paths() # Add paths specified in the environment variables LDFLAGS and # CPPFLAGS for header and library files. |