summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorEric Snow <ericsnowcurrently@gmail.com>2019-03-01 23:50:31 (GMT)
committerGitHub <noreply@github.com>2019-03-01 23:50:31 (GMT)
commitbcfa450f210074e16feb761ae5b3e966a2532fcf (patch)
treef35f16dc1d0689236065b87ac2a3d65f44c90c91 /setup.py
parent1f24a719e7be5e49b876a5dc7daf21d01ee69faa (diff)
downloadcpython-bcfa450f210074e16feb761ae5b3e966a2532fcf.zip
cpython-bcfa450f210074e16feb761ae5b3e966a2532fcf.tar.gz
cpython-bcfa450f210074e16feb761ae5b3e966a2532fcf.tar.bz2
bpo-36097: Use only public C-API in the_xxsubinterpreters module (adding as necessary). (#12003)
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 1 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index b969610..c278f08 100644
--- a/setup.py
+++ b/setup.py
@@ -784,9 +784,7 @@ class PyBuildExt(build_ext):
self.add(Extension('syslog', ['syslogmodule.c']))
# Python interface to subinterpreter C-API.
- self.add(Extension('_xxsubinterpreters',
- ['_xxsubinterpretersmodule.c'],
- define_macros=[('Py_BUILD_CORE', '')]))
+ self.add(Extension('_xxsubinterpreters', ['_xxsubinterpretersmodule.c']))
#
# Here ends the simple stuff. From here on, modules need certain