summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorKyle Evans <kevans91@users.noreply.github.com>2020-10-13 20:04:44 (GMT)
committerGitHub <noreply@github.com>2020-10-13 20:04:44 (GMT)
commit7992579cd27f14f472acc37aca537eec55f681ef (patch)
tree5d738707fbf658dcbd2ddc6aaf0cf107b92bec45 /setup.py
parent8b2ff4c03d150c43df3e8438d323b7f7bfe3353c (diff)
downloadcpython-7992579cd27f14f472acc37aca537eec55f681ef.zip
cpython-7992579cd27f14f472acc37aca537eec55f681ef.tar.gz
cpython-7992579cd27f14f472acc37aca537eec55f681ef.tar.bz2
bpo-40422: Move _Py_closerange to fileutils.c (GH-22680)
This API is relatively lightweight and organizationally, given that it's used by multiple modules, it makes sense to move it to fileutils. Requires making sure that _posixsubprocess is compiled with the appropriate Py_BUIILD_CORE_BUILTIN macro.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 476f8c4..d3fd7bc 100644
--- a/setup.py
+++ b/setup.py
@@ -950,7 +950,8 @@ class PyBuildExt(build_ext):
self.add(Extension('_csv', ['_csv.c']))
# POSIX subprocess module helper.
- self.add(Extension('_posixsubprocess', ['_posixsubprocess.c']))
+ self.add(Extension('_posixsubprocess', ['_posixsubprocess.c'],
+ extra_compile_args=['-DPy_BUILD_CORE_MODULE']))
def detect_test_extensions(self):
# Python C API test module