diff options
author | Kyle Evans <kevans91@users.noreply.github.com> | 2020-10-13 20:04:44 (GMT) |
---|---|---|
committer | GitHub <noreply@github.com> | 2020-10-13 20:04:44 (GMT) |
commit | 7992579cd27f14f472acc37aca537eec55f681ef (patch) | |
tree | 5d738707fbf658dcbd2ddc6aaf0cf107b92bec45 /setup.py | |
parent | 8b2ff4c03d150c43df3e8438d323b7f7bfe3353c (diff) | |
download | cpython-7992579cd27f14f472acc37aca537eec55f681ef.zip cpython-7992579cd27f14f472acc37aca537eec55f681ef.tar.gz cpython-7992579cd27f14f472acc37aca537eec55f681ef.tar.bz2 |
bpo-40422: Move _Py_closerange to fileutils.c (GH-22680)
This API is relatively lightweight and organizationally, given that it's
used by multiple modules, it makes sense to move it to fileutils.
Requires making sure that _posixsubprocess is compiled with the appropriate
Py_BUIILD_CORE_BUILTIN macro.
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 3 |
1 files changed, 2 insertions, 1 deletions
@@ -950,7 +950,8 @@ class PyBuildExt(build_ext): self.add(Extension('_csv', ['_csv.c'])) # POSIX subprocess module helper. - self.add(Extension('_posixsubprocess', ['_posixsubprocess.c'])) + self.add(Extension('_posixsubprocess', ['_posixsubprocess.c'], + extra_compile_args=['-DPy_BUILD_CORE_MODULE'])) def detect_test_extensions(self): # Python C API test module |