summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorMiss Islington (bot) <31488909+miss-islington@users.noreply.github.com>2022-05-19 16:51:08 (GMT)
committerGitHub <noreply@github.com>2022-05-19 16:51:08 (GMT)
commit0f1748d66e3acfd897297218fa1d552e587f7467 (patch)
tree034b2f2d3495f39ae0e599261742a270ae008e74 /setup.py
parent37d60c0255f4404080e2a329b80b253c8221762d (diff)
downloadcpython-0f1748d66e3acfd897297218fa1d552e587f7467.zip
cpython-0f1748d66e3acfd897297218fa1d552e587f7467.tar.gz
cpython-0f1748d66e3acfd897297218fa1d552e587f7467.tar.bz2
gh-78630: Drop invalid HP aCC compiler switch -fPIC on HP-UX (GH-8847)
At compile time, '+z' is already properly used with HP aCC, and shared libraries are correctly linked with '+b'. The '-fPIC' switch can safely be dropped. (cherry picked from commit 09be18a73d81aa82cc57a782f3b0a9811e43ad3b) Co-authored-by: Michael Osipov <michael.osipov@siemens.com>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 0 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index f45cd6d..4c49734 100644
--- a/setup.py
+++ b/setup.py
@@ -1408,9 +1408,6 @@ class PyBuildExt(build_ext):
# finding some -z option for the Sun compiler.
extra_link_args.append('-mimpure-text')
- elif HOST_PLATFORM.startswith('hp-ux'):
- extra_link_args.append('-fPIC')
-
ext = Extension('_ctypes',
include_dirs=include_dirs,
extra_compile_args=extra_compile_args,