diff options
author | Xavier de Gaye <xdegaye@users.sourceforge.net> | 2016-12-14 10:14:33 (GMT) |
---|---|---|
committer | Xavier de Gaye <xdegaye@users.sourceforge.net> | 2016-12-14 10:14:33 (GMT) |
commit | 1351c31aa9651b278d7ef8ec79af3b646a520235 (patch) | |
tree | 82c8a8dead962202ac8f9ab1b29b67f0535630e8 /setup.py | |
parent | 7262b42fd13bc8ac5b3d2cb9073dda3d3503e831 (diff) | |
download | cpython-1351c31aa9651b278d7ef8ec79af3b646a520235.zip cpython-1351c31aa9651b278d7ef8ec79af3b646a520235.tar.gz cpython-1351c31aa9651b278d7ef8ec79af3b646a520235.tar.bz2 |
Issue #20211: Do not add the directory for installing C header files and
the directory for installing object code libraries to the cross compilation
search paths.
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 5 |
1 files changed, 3 insertions, 2 deletions
@@ -532,8 +532,9 @@ class PyBuildExt(build_ext): for directory in reversed(options.dirs): add_dir_to_list(dir_list, directory) - if os.path.normpath(sys.base_prefix) != '/usr' \ - and not sysconfig.get_config_var('PYTHONFRAMEWORK'): + if (not cross_compiling and + os.path.normpath(sys.base_prefix) != '/usr' and + not sysconfig.get_config_var('PYTHONFRAMEWORK')): # OSX note: Don't add LIBDIR and INCLUDEDIR to building a framework # (PYTHONFRAMEWORK is set) to avoid # linking problems when # building a framework with different architectures than |