diff options
author | Christian Heimes <christian@python.org> | 2021-11-08 11:48:34 (GMT) |
---|---|---|
committer | GitHub <noreply@github.com> | 2021-11-08 11:48:34 (GMT) |
commit | 24af9a40a8f85af813ea89998aa4e931fcc78cd9 (patch) | |
tree | a9da84c63fd4eaa18e7cd5c5d11c652289f4d62e /setup.py | |
parent | 122ca4d73faba279a579aa2011fa34661ce537a2 (diff) | |
download | cpython-24af9a40a8f85af813ea89998aa4e931fcc78cd9.zip cpython-24af9a40a8f85af813ea89998aa4e931fcc78cd9.tar.gz cpython-24af9a40a8f85af813ea89998aa4e931fcc78cd9.tar.bz2 |
bpo-45743: Move __APPLE_USE_RFC_3542 into socketmodule.c (GH-29456)
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 8 |
1 files changed, 1 insertions, 7 deletions
@@ -1222,13 +1222,7 @@ class PyBuildExt(build_ext): self.add(Extension('_crypt', ['_cryptmodule.c'], libraries=libs)) def detect_socket(self): - # socket(2) - kwargs = {'depends': ['socketmodule.h']} - if MACOS: - # Issue #35569: Expose RFC 3542 socket options. - kwargs['extra_compile_args'] = ['-D__APPLE_USE_RFC_3542'] - - self.add(Extension('_socket', ['socketmodule.c'], **kwargs)) + self.add(Extension('_socket', ['socketmodule.c'], depends=['socketmodule.h'])) def detect_dbm_gdbm(self): # Modules that provide persistent dictionary-like semantics. You will |