diff options
author | Guido van Rossum <guido@python.org> | 2002-08-06 17:28:30 (GMT) |
---|---|---|
committer | Guido van Rossum <guido@python.org> | 2002-08-06 17:28:30 (GMT) |
commit | 8cdc03dca571fd2847d68bfd220234c0153f8f47 (patch) | |
tree | acc4439d78e490bb4c2ab6527b038b597c8b26a9 /setup.py | |
parent | 0855dd8938664143fd66835aca94f0b4c6dc9d0a (diff) | |
download | cpython-8cdc03dca571fd2847d68bfd220234c0153f8f47.zip cpython-8cdc03dca571fd2847d68bfd220234c0153f8f47.tar.gz cpython-8cdc03dca571fd2847d68bfd220234c0153f8f47.tar.bz2 |
Update the URL for getting zlib, and update the minimal required
version to 1.1.4 (because of the 1.1.3 security problem). Also
replace a funny use of line.find() with line.startswith().
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 8 |
1 files changed, 4 insertions, 4 deletions
@@ -653,19 +653,19 @@ class PyBuildExt(build_ext): # Andrew Kuchling's zlib module. - # This require zlib 1.1.3 (or later). - # See http://www.cdrom.com/pub/infozip/zlib/ + # This requires zlib 1.1.4 (1.1.3 has a security problem). + # See http://www.gzip.org/zlib/ zlib_inc = find_file('zlib.h', [], inc_dirs) if zlib_inc is not None: zlib_h = zlib_inc[0] + '/zlib.h' version = '"0.0.0"' - version_req = '"1.1.3"' + version_req = '"1.1.4"' fp = open(zlib_h) while 1: line = fp.readline() if not line: break - if line.find('#define ZLIB_VERSION', 0) == 0: + if line.startswith('#define ZLIB_VERSION'): version = line.split()[2] break if version >= version_req: |