diff options
author | Alexander Belopolsky <alexander.belopolsky@gmail.com> | 2010-06-16 22:38:15 (GMT) |
---|---|---|
committer | Alexander Belopolsky <alexander.belopolsky@gmail.com> | 2010-06-16 22:38:15 (GMT) |
commit | d95a586d7760731c6c842a1bdfdbb572257bb8ed (patch) | |
tree | 252a1a2c0b5165ed85414163a6afa3a70bfb3c6c /setup.py | |
parent | 294f27141f170a09916341a8fcc49903b8e4359e (diff) | |
download | cpython-d95a586d7760731c6c842a1bdfdbb572257bb8ed.zip cpython-d95a586d7760731c6c842a1bdfdbb572257bb8ed.tar.gz cpython-d95a586d7760731c6c842a1bdfdbb572257bb8ed.tar.bz2 |
Issue #9012: "Separate compilation of time and datetime modules."
Segregated code shared between time and datetime modules into
Modules/_time.c. Added a new header file, Modules/_time.h, which
will be used instead of Include/timefuncs.h for declarations shared
between time and datetime modules.
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 4 |
1 files changed, 2 insertions, 2 deletions
@@ -450,9 +450,9 @@ class PyBuildExt(build_ext): depends=['_math.h'], libraries=math_libs) ) # time operations and variables - exts.append( Extension('time', ['timemodule.c'], + exts.append( Extension('time', ['timemodule.c', '_time.c'], libraries=math_libs) ) - exts.append( Extension('datetime', ['datetimemodule.c', 'timemodule.c'], + exts.append( Extension('datetime', ['datetimemodule.c', '_time.c'], libraries=math_libs) ) # fast iterator tools implemented in C exts.append( Extension("itertools", ["itertoolsmodule.c"]) ) |