summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorcolorfulappl <colorfulappl@qq.com>2022-12-17 06:34:54 (GMT)
committerGitHub <noreply@github.com>2022-12-17 06:34:54 (GMT)
commitdd323afea81523482e14c57eaebd6d3c7d61c212 (patch)
tree13c15ecad64f993b807b6003f83e37baf02453c2 /setup.py
parent4c810f92baed7562e7f2da0c70e2edac2e89bf75 (diff)
downloadcpython-dd323afea81523482e14c57eaebd6d3c7d61c212.zip
cpython-dd323afea81523482e14c57eaebd6d3c7d61c212.tar.gz
cpython-dd323afea81523482e14c57eaebd6d3c7d61c212.tar.bz2
[3.11] gh-96002: Add functional test for Argument Clinic (GH-96178) (#100230)
(cherry picked from commit c450c8c9ed6e420025f39d0e4850a79f8160cdcd) Co-authored-by: Kumar Aditya <59607654+kumaraditya303@users.noreply.github.com> Co-authored-by: Erlend E. Aasland <erlend.aasland@protonmail.com>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 3 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 15d0d45..4f122b6 100644
--- a/setup.py
+++ b/setup.py
@@ -1012,6 +1012,9 @@ class PyBuildExt(build_ext):
# Python C API test module
self.addext(Extension('_testcapi', ['_testcapimodule.c']))
+ # Python Argument Clinc functional test module
+ self.addext(Extension('_testclinic', ['_testclinic.c']))
+
# Python Internal C API test module
self.addext(Extension('_testinternalcapi', ['_testinternalcapi.c']))