summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorGuido van Rossum <guido@python.org>2002-09-25 14:59:57 (GMT)
committerGuido van Rossum <guido@python.org>2002-09-25 14:59:57 (GMT)
commitfa8218143691f46195b7bc5c0b66fb5d036c4271 (patch)
tree18c6b41ba30f224281eb67e6d4deba4db46a7de5 /setup.py
parent111ee3208f546477af15ded1f48031df8126f96e (diff)
downloadcpython-fa8218143691f46195b7bc5c0b66fb5d036c4271.zip
cpython-fa8218143691f46195b7bc5c0b66fb5d036c4271.tar.gz
cpython-fa8218143691f46195b7bc5c0b66fb5d036c4271.tar.bz2
Disable building of the fpectl module -- it's dangerous or useless
except in the hands of experts. Will backport to 2.2.2.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py29
1 files changed, 15 insertions, 14 deletions
diff --git a/setup.py b/setup.py
index 7e9d7fe..7328534 100644
--- a/setup.py
+++ b/setup.py
@@ -652,20 +652,21 @@ class PyBuildExt(build_ext):
# The library to link fpectl with is platform specific.
# Choose *one* of the options below for fpectl:
- if platform == 'irix5':
- # For SGI IRIX (tested on 5.3):
- exts.append( Extension('fpectl', ['fpectlmodule.c'],
- libraries=['fpe']) )
- elif 0: # XXX how to detect SunPro?
- # For Solaris with SunPro compiler (tested on Solaris 2.5
- # with SunPro C 4.2): (Without the compiler you don't have
- # -lsunmath.)
- #fpectl fpectlmodule.c -R/opt/SUNWspro/lib -lsunmath -lm
- pass
- else:
- # For other systems: see instructions in fpectlmodule.c.
- #fpectl fpectlmodule.c ...
- exts.append( Extension('fpectl', ['fpectlmodule.c']) )
+ # Disabled; it's dangerous or useless except in the hands of experts.
+## if platform == 'irix5':
+## # For SGI IRIX (tested on 5.3):
+## exts.append( Extension('fpectl', ['fpectlmodule.c'],
+## libraries=['fpe']) )
+## elif 0: # XXX how to detect SunPro?
+## # For Solaris with SunPro compiler (tested on Solaris 2.5
+## # with SunPro C 4.2): (Without the compiler you don't have
+## # -lsunmath.)
+## #fpectl fpectlmodule.c -R/opt/SUNWspro/lib -lsunmath -lm
+## pass
+## else:
+## # For other systems: see instructions in fpectlmodule.c.
+## #fpectl fpectlmodule.c ...
+## exts.append( Extension('fpectl', ['fpectlmodule.c']) )
# Andrew Kuchling's zlib module. Note that some versions of zlib