summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorGregory P. Smith <greg@mad-scientist.com>2010-01-03 00:43:02 (GMT)
committerGregory P. Smith <greg@mad-scientist.com>2010-01-03 00:43:02 (GMT)
commitffd5d886c2eb95c04e37736058994b263b2ab424 (patch)
tree9c2e27200b96e6e85b6c9a63682b423143b1c141 /setup.py
parent6dcdcde2a889ce6937c9c42552c665067fe0dde2 (diff)
downloadcpython-ffd5d886c2eb95c04e37736058994b263b2ab424.zip
cpython-ffd5d886c2eb95c04e37736058994b263b2ab424.tar.gz
cpython-ffd5d886c2eb95c04e37736058994b263b2ab424.tar.bz2
make setup.py similar to py3k's when reporting on _hashlib as missing or not.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py26
1 files changed, 14 insertions, 12 deletions
diff --git a/setup.py b/setup.py
index c2c01ee..30f2e85 100644
--- a/setup.py
+++ b/setup.py
@@ -657,19 +657,22 @@ class PyBuildExt(build_ext):
#print 'openssl_ver = 0x%08x' % openssl_ver
min_openssl_ver = 0x00907000
- have_usable_openssl = (ssl_incs is not None and
- ssl_libs is not None and
+ have_any_openssl = ssl_incs is not None and ssl_libs is not None
+ have_usable_openssl = (have_any_openssl and
openssl_ver >= min_openssl_ver)
- if have_usable_openssl:
- # The _hashlib module wraps optimized implementations
- # of hash functions from the OpenSSL library.
- exts.append( Extension('_hashlib', ['_hashopenssl.c'],
- include_dirs = ssl_incs,
- library_dirs = ssl_libs,
- libraries = ['ssl', 'crypto']) )
- # these aren't strictly missing since they are unneeded.
- #missing.extend(['_sha', '_md5'])
+ if have_any_openssl:
+ if have_usable_openssl:
+ # The _hashlib module wraps optimized implementations
+ # of hash functions from the OpenSSL library.
+ exts.append( Extension('_hashlib', ['_hashopenssl.c'],
+ include_dirs = ssl_incs,
+ library_dirs = ssl_libs,
+ libraries = ['ssl', 'crypto']) )
+ else:
+ print ("warning: openssl 0x%08x is too old for _hashlib" %
+ openssl_ver)
+ missing.append('_hashlib')
if COMPILED_WITH_PYDEBUG or not have_usable_openssl:
# The _sha module implements the SHA1 hash algorithm.
exts.append( Extension('_sha', ['shamodule.c']) )
@@ -679,7 +682,6 @@ class PyBuildExt(build_ext):
exts.append( Extension('_md5',
sources = ['md5module.c', 'md5.c'],
depends = ['md5.h']) )
- missing.append('_hashlib')
min_sha2_openssl_ver = 0x00908000
if COMPILED_WITH_PYDEBUG or openssl_ver < min_sha2_openssl_ver: