diff options
author | Thomas Heller <theller@ctypes.org> | 2008-05-20 19:53:47 (GMT) |
---|---|---|
committer | Thomas Heller <theller@ctypes.org> | 2008-05-20 19:53:47 (GMT) |
commit | 03b75ddf7c63bb7b7bc1b424661c94076b57be9e (patch) | |
tree | 8dfbbc2c4c42ee32f987eafdfd0d29dd8cfbac65 /setup.py | |
parent | c01288387c47a75cab059a6d0c6dfe4cb9eff2de (diff) | |
download | cpython-03b75ddf7c63bb7b7bc1b424661c94076b57be9e.zip cpython-03b75ddf7c63bb7b7bc1b424661c94076b57be9e.tar.gz cpython-03b75ddf7c63bb7b7bc1b424661c94076b57be9e.tar.bz2 |
On HPUX, -fPIC must be used for linking. _ctypes now builds on HP-UX
IA64 and PA machines.
The ctypes unittests work fine on the IA64, but dump core in
test_qsort on the PA.
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 3 |
1 files changed, 3 insertions, 0 deletions
@@ -1580,6 +1580,9 @@ class PyBuildExt(build_ext): # finding some -z option for the Sun compiler. extra_link_args.append('-mimpure-text') + elif sys.platform.startswith('hpux'): + extra_link_args.append('-fPIC') + ext = Extension('_ctypes', include_dirs=include_dirs, extra_compile_args=extra_compile_args, |