diff options
author | Chih-Hsuan Yen <yan12125@gmail.com> | 2018-07-11 08:48:43 (GMT) |
---|---|---|
committer | INADA Naoki <methane@users.noreply.github.com> | 2018-07-11 08:48:43 (GMT) |
commit | 09b2bece78f62c3d363236dce593ecfe130afd2f (patch) | |
tree | 5c956ce1c212616db4c18b38d5c53c63b6ecd1c6 /setup.py | |
parent | d5c875bbf1ef9b24349d3243b1ffaab6a9d5a78e (diff) | |
download | cpython-09b2bece78f62c3d363236dce593ecfe130afd2f.zip cpython-09b2bece78f62c3d363236dce593ecfe130afd2f.tar.gz cpython-09b2bece78f62c3d363236dce593ecfe130afd2f.tar.bz2 |
bpo-29442: Replace optparse with argparse in setup.py (GH-139)
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 23 |
1 files changed, 4 insertions, 19 deletions
@@ -1,7 +1,7 @@ # Autodetecting setup.py script for building the Python extensions # -import sys, os, importlib.machinery, re, optparse +import sys, os, importlib.machinery, re, argparse from glob import glob import importlib._bootstrap import importlib.util @@ -560,24 +560,9 @@ class PyBuildExt(build_ext): ('CPPFLAGS', '-I', self.compiler.include_dirs)): env_val = sysconfig.get_config_var(env_var) if env_val: - # To prevent optparse from raising an exception about any - # options in env_val that it doesn't know about we strip out - # all double dashes and any dashes followed by a character - # that is not for the option we are dealing with. - # - # Please note that order of the regex is important! We must - # strip out double-dashes first so that we don't end up with - # substituting "--Long" to "-Long" and thus lead to "ong" being - # used for a library directory. - env_val = re.sub(r'(^|\s+)-(-|(?!%s))' % arg_name[1], - ' ', env_val) - parser = optparse.OptionParser() - # Make sure that allowing args interspersed with options is - # allowed - parser.allow_interspersed_args = True - parser.error = lambda msg: None - parser.add_option(arg_name, dest="dirs", action="append") - options = parser.parse_args(env_val.split())[0] + parser = argparse.ArgumentParser() + parser.add_argument(arg_name, dest="dirs", action="append") + options, _ = parser.parse_known_args(env_val.split()) if options.dirs: for directory in reversed(options.dirs): add_dir_to_list(dir_list, directory) |