diff options
author | Antoine Pitrou <solipsis@pitrou.net> | 2010-01-13 11:57:42 (GMT) |
---|---|---|
committer | Antoine Pitrou <solipsis@pitrou.net> | 2010-01-13 11:57:42 (GMT) |
commit | 1379b8404a8013932299f02d0a2e081200386a49 (patch) | |
tree | ca3c3f7deff75d402e2dc8e7824ac2d9c11a3dae /setup.py | |
parent | 8c510e704e3823df66c2c3ad85912c9a9dda7f14 (diff) | |
download | cpython-1379b8404a8013932299f02d0a2e081200386a49.zip cpython-1379b8404a8013932299f02d0a2e081200386a49.tar.gz cpython-1379b8404a8013932299f02d0a2e081200386a49.tar.bz2 |
Use `with`
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 3 |
1 files changed, 2 insertions, 1 deletions
@@ -1732,7 +1732,8 @@ class PyBuildExt(build_ext): return False fficonfig = {} - exec open(ffi_configfile) in fficonfig + with open(ffi_configfile) as f: + exec f in fficonfig # Add .S (preprocessed assembly) to C compiler source extensions. self.compiler_obj.src_extensions.append('.S') |