diff options
author | Victor Stinner <vstinner@python.org> | 2020-12-14 22:07:54 (GMT) |
---|---|---|
committer | GitHub <noreply@github.com> | 2020-12-14 22:07:54 (GMT) |
commit | 357704c9f2375f29ed5b3a93adac086fa714538d (patch) | |
tree | 8b69403f419da52a6728c8557e1169aaf23c9e2e /setup.py | |
parent | 83d52044ae4def1e8611a4b1b9263b850ca5c458 (diff) | |
download | cpython-357704c9f2375f29ed5b3a93adac086fa714538d.zip cpython-357704c9f2375f29ed5b3a93adac086fa714538d.tar.gz cpython-357704c9f2375f29ed5b3a93adac086fa714538d.tar.bz2 |
bpo-42639: atexit now logs callbacks exceptions (GH-23771)
At Python exit, if a callback registered with atexit.register()
fails, its exception is now logged. Previously, only some exceptions
were logged, and the last exception was always silently ignored.
Add _PyAtExit_Call() function and remove
PyInterpreterState.atexit_func member. call_py_exitfuncs() now calls
directly _PyAtExit_Call().
The atexit module must now always be built as a built-in module.
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 2 |
1 files changed, 0 insertions, 2 deletions
@@ -854,8 +854,6 @@ class PyBuildExt(build_ext): # C-optimized pickle replacement self.add(Extension("_pickle", ["_pickle.c"], extra_compile_args=['-DPy_BUILD_CORE_MODULE'])) - # atexit - self.add(Extension("atexit", ["atexitmodule.c"])) # _json speedups self.add(Extension("_json", ["_json.c"], extra_compile_args=['-DPy_BUILD_CORE_MODULE'])) |