summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorNed Deily <nad@acm.org>2012-07-30 11:09:32 (GMT)
committerNed Deily <nad@acm.org>2012-07-30 11:09:32 (GMT)
commit3b796680c3cbc1d43f3e1157cacc8e6b668f65f6 (patch)
tree69d0eaabce5fd2bed0bddecb59a005ede32a7e29 /setup.py
parentc556c6440593c36cdfd407a6e192de86ac1b0df6 (diff)
downloadcpython-3b796680c3cbc1d43f3e1157cacc8e6b668f65f6.zip
cpython-3b796680c3cbc1d43f3e1157cacc8e6b668f65f6.tar.gz
cpython-3b796680c3cbc1d43f3e1157cacc8e6b668f65f6.tar.bz2
Issue #14018: Fix OS X Tcl/Tk framework checking when using OS X SDKs.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 3 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 2539f50..f3886bf 100644
--- a/setup.py
+++ b/setup.py
@@ -60,6 +60,9 @@ def is_macosx_sdk_path(path):
Returns True if 'path' can be located in an OSX SDK
"""
return (path.startswith('/usr/') and not path.startswith('/usr/local')) or path.startswith('/System/')
+ return ( (path.startswith('/usr/') and not path.startswith('/usr/local'))
+ or path.startswith('/System/')
+ or path.startswith('/Library/') )
def find_file(filename, std_dirs, paths):
"""Searches for the directory where a given file is located,